Существует несколько способов начать использовать Sass:

  1. Приложения

    Мышь

    Есть множество приложений под Windows, Mac и Linux, которые помогут в освоении и работе с Sass. Большинство из них бесплатные, но некоторые из них все-таки платные (но это того стоит).

  2. Командная строка

    Keyboard

    Когда вы используете Sass через командную строку, то для того, чтобы запустить компиляцию .sass и .scss в .css файлы введите команду sass. Например:

    sass source/stylesheets/index.scss build/stylesheets/index.css
    

    Используя любой способ установки Sass, запустите команду sass --version чтобы быть уверенным, что установка прошла успешно. Если эту команду выполнить, то в ответ вы получите версию Sass 1.5.1. Также вы можете запустить команду sass --help для получения информации по использованию Sass в командной строке.

    Как только все настроено, начинайте наслаждаться. Если вы впервые столкнулись с Sass, то специально для вас мы создали несколько ресурсов для обучения.

    Узнать больше о Sass

    Установка в любом месте (Standalone)
    Вы можете установить Sass в Windows, Mac, или Linux путем скачивания дистрибутива для вашей операционной системы from GitHub и выполните действия с PATH. Вот и все: никаких зависимостей нет и ничего не нужно устанавливать дополнительно.
    Установка в любом месте (npm)

    Если вы используете Node.js, то вы можете установить Sass c помощью npm:

    npm install -g sass
    
    Однако, учтите, что это установит реализацию Sass на нативном JavaScript, которая работает несколько медленнее, чем другие реализации, перечисленные здесь. Но он имеет тот же интерфейс, поэтому будет легче поменять на другую реализацию позже, если вам потребуется немного больше скорости!
    Установка в Windows (Chocolatey)

    Если вы используете менеджер пакетов Chocolatey для Windows, вы можете установить Dart Sass при помощи команды:

    choco install sass
    
    Установка в Mac OS X (Homebrew)

    Если вы используете менеджер пакетов Homebrew для Mac OS X, вы можете установить Dart Sass при помощи команды:

    brew install --devel sass/sass/sass